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This chapter discusses standard procedures for managing
QuicKeys on a day-to-day basis. It also provides information
on turning individual Shortcuts on and off, resolving
keystroke conflicts, and importing and exporting Shortcuts.

SAVING SHORTCUTS
Your Shortcuts are automatically saved whenever you close
the QuicKeys Editor.

EDITING SHORTCUTS
To edit QuicKeys Shortcuts, open the QuicKeys Editor and
double-click the Shortcut you want to edit. Make changes in
the Shortcut Properties dialog that appears and click OK when
you are finished.

DELETING SHORTCUTS
To delete QuicKeys Shortcuts, open the QuicKeys Editor and
select the Shortcut you want to delete. Select Delete from the Edit
menu. Click the Delete button in the alert window that appears.

▲ There is no “Undo” function if you delete a Shortcut.

PRINTING SHORTCUTS
If you want to print a list of your Shortcuts, choose the keyset
you want to print and select Print from the File menu. The
following information in the selected Set is printed:
• Keystroke.
• Icon representing Shortcut type.
• Shortcut name.
• Comments.

MANAGING KEYSTROKE ASSIGNMENTS
If you have created several Shortcuts, you may find it difficult
to keep track of all your keystroke assignments. If it becomes
hard to remember which key combinations trigger your
favorite Shortcuts, you can either print a list of your Shortcuts
or view the QuickReference Card.

PRINTING KEYSTROKE ASSIGNMENTS
To print a list of keystroke assignments in a QuicKeys Set,
open the QuicKeys Editor and select the QuicKeys Set you
want to print. Choose Print from the File menu and click OK in
the Print dialog that appears. The keystroke, Shortcut type,
Shortcut name, and a comment line are printed for the
QuicKeys Set you selected.

••••
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VIEWING THE QUICKREFERENCE CARD
QuicKeys provides another solution to “keystroke overload”
with the QuickReference Card. The QuickReference Card is a
modal window that displays QuicKeys Shortcuts and their
corresponding keystroke assignments for your Universal and
active applications Sets. You can trigger Shortcuts by clicking
them in the QuickReference Card, or you can simply use the
QuickReference Card to view the Shortcuts you have created.

• Click Show all to display all the Shortcuts.
• Click on one of the filter buttons to display only the
Shortcuts represented by that button.
• Press the Shift key down and click multiple filter buttons
to display multiple Shortcut types. A black outline
highlights the selected plug-ins in the filter.
• Click the arrow button to scroll through the
QuickReference Card.

CLEARING KEYSTROKE ASSIGNMENTS
There are three areas where you can delete your keystroke
assignment for a particular Shortcut: from the QuicKeys
Editor Keysets tab and from the Shortcut Properties dialog.
• To delete a keystroke assignment from the QuicKeys
Editor Keysets tab, click in the Keystroke column and press
the Delete key on your keyboard. The keystroke cell
becomes blank.

Figure 61: The QuickReference Card.
By default, the QuickReference Card can be opened by
selecting QuickReference Card from the QuicKeys menu or by
pressing Option+Control+Space. The QuickReference Card
closes when you press the OK button or when you click a
Shortcut listed in the QuickReference Card window.
You can choose which QuicKeys Shortcuts appear in the
QuickReference Card using the filtering toolbar at the bottom
of the QuickReference Card window. Each button on the
toolbar represents a type of QuicKeys plug-in. By default, all
plug-ins display in the QuickReference Card.

• To delete a keystroke assignment from the Shortcut
Properties dialog, position your cursor in the keystroke
box of the Shortcut Properties dialog and press the Delete
key on your keyboard. The keystroke is replaced by the
word “unassigned” to indicate that the Shortcut no longer
has a keystroke trigger assigned to it.
• Select the Shortcut in the QuicKeys Editor and select
Undefine from the Edit menu.

RESOLVING KEYSTROKE CONFLICTS
Keystroke conflicts occur when a keystroke in one QuicKeys
Shortcut Set conflicts with a keystroke in another QuicKeys
Set. Conflicts can also occur between QuicKeys keystrokes
and keystrokes that are built into another application. For
example, let’s say the F5 keystroke is assigned to two different
QuicKeys Shortcuts. One keystroke opens Photoshop and is
part of the Universal Set. The other keystroke changes the
layout of a document and can only be triggered in a specific
database application. What happens when you press F5?

••••

QuicKeys follows specific rules of priority to resolve
keystroke conflicts. When the same keystroke is used for
several different tasks, the resulting Shortcut depends upon
where the keystroke falls in the following hierarchy:
A. Application-specific keystrokes
B. Universal keystrokes
C. Keystrokes defined within a particular application
Applying this information to the above example, if the
database program is the active application, F5 formats a
database document. If the database program is not the active
program, F5 starts Photoshop.
If you don’t want to change assigned keystrokes to avoid
these conflicts, you can either use the QuicKeys Specials
plug-in to turn your keystrokes on and off for a brief period of
time or you can substitute QuicKeys keystrokes for the
keystrokes that are built into the applications you use.

Turning Off Keystroke Assignments
If keystroke conflicts only occur in applications you seldom
use, the best way to avoid them is to turn your QuicKeys
keystrokes on and off using the Specials plug-in. This feature
enables you to briefly disable a QuicKeys keystroke while you
work in an application that uses conflicting keystrokes.
For example, you may want to disable QuicKeys keystrokes
while working in Microsoft Excel if Excel uses Command+I to
insert cells, but you have directed QuicKeys to use
Command+I to change selected text to italics in your
Universal Set.
When you are finished working in the application, you can
turn QuicKeys keystrokes back on. See page 111 for more
information.
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Reassigning Built-in Application Keystrokes
If keystroke conflicts occur in applications you use on a daily
basis, you need to change either the keystroke that you
assigned with QuicKeys or the keystroke your applications
use. You can change your QuicKeys keystrokes simply by
opening the QuicKeys Editor, positioning your cursor in the
Keystroke column and pressing a different keystroke when
you see the blinking cursor.
To change your built-in application keystrokes, you can use
the Alias Keystroke Shortcut. See page 95 for more
information.

WORKING WITH QUICKEYS SETS
You can specify the range of operation for a particular
QuicKeys Shortcut by choosing a QuicKeys Set. These Sets
make it easier to manage QuicKeys because they enable you
to categorize your Shortcuts. You can place a Shortcut in the
Universal Set so it can be triggered at any time, or you can
make a Shortcut application-specific so it only works in a
selected application.

••••
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Selecting the Universal Set
Use the Universal Set when you want to be able to trigger a
Shortcut at any time, regardless of what application you are in
or whether or not the Finder is active.

INACTIVE SETS
Inactive Sets include all QuicKeys Sets that reside in your
Keysets folder, with the exception of the active application Set
and the Universal Set.

Selecting an Application Set
There are two different application Sets: an active application
Set and a standard application Set. The active application Set
enables you to assign Shortcuts to the application that is active
on your desktop. The standard application Set enables you to
choose which application Set you want to view. The
application list contains:
• Applications that currently have QuicKeys Shortcuts
assigned to them.
Figure 62: Choose which Set you want a particular Shortcut to belong to
using the Set pop-up menu.
When you open the QuicKeys Editor, you can choose to view
three different kinds of Sets: Active Sets, Inactive Sets, and
Custom Sets.

ACTIVE SETS
There are only two active Sets at any one time in QuicKeys:
the Universal Set and the current application Set. Shortcuts
can only be triggered if they are in an active Set. On a Mac, the
active application is denoted by a checkmark in the
application menu. In QuicKeys, the active application is
displayed in the Sets pop-up menu of the QuicKeys Editor.
Shortcuts listed in an application Set can only be triggered
when the application is frontmost on the desktop. For
example, if the Finder is the active application, only Universal
and Finder-specific shortcuts can be triggered.

• Applications that are currently launched.
• The Finder.

CUSTOM SETS
Sets that are not stored in the Keysets folder are called Custom
Sets. To open custom Sets, you must select Open Set from the File
menu and navigate to the location of the Set.

Creating a Custom QuicKeys Set
You can create custom QuicKeys Sets for applications, such as
computer games. For example, if you are an avid fan of
computer games, you may find that you cannot interrupt a
game to make a QuicKeys Shortcut. If this occurs, you can
“trick” the game by creating a custom QuicKeys Set.

••••

To create a custom QuicKeys Set:
1. Open the QuicKeys Editor.
2. Select New Set from the File menu.
3. Type a name for your custom Set. If you are using the
Shortcuts for a game, the name of your custom Set must
match the name of the game you are trying to automate
with QuicKeys.
4. Choose to store the Set in the Keysets folder. The
Keysets folder is located in the :System
Folder:Preferences:QuicKeys Folder: on your startup disk.
5. Click Save to save your Set to the Keysets folder. The
QuicKeys Editor appears with the name of your new Set
displayed in the Sets pop-up menu.
6. Add Shortcuts to your custom Set.
The next time you open the computer game, it automatically
recognizes the Shortcuts you have assigned to it using
QuicKeys.

Opening Custom QuicKeys Sets
To open a custom QuicKeys Set:
1. Open the QuicKeys Editor.
2. Select Open Set from the QuicKeys Editor File menu.
3. Navigate to the custom QuicKeys Set you want to display
and click Open. The selected Set appears in the QuicKeys
Editor.

Saving Sets
To save a custom QuicKeys Set, select Save from the File menu.

CHANGING SET ASSIGNMENTS
To change Set assignments, use the cut, copy, and paste
options to remove Shortcuts from one Set and add them to
another Set.
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CLOSING SETS
To close a custom QuicKeys Set so it no longer appears in the
QuicKeys Editor, select a Set from the Set pop-up menu and
choose Close Set from the File menu.

HIDING QUICKEYS
When you click outside of the QuicKeys Editor, the Editor
window is replaced by a small, boxed QuicKeys logo called
the QuicKeys palette. When you click on the QuicKeys
palette, the QuicKeys Editor reappears. This functionality
enables you to “hide” the QuicKeys Editor without closing it.

Figure 63: The QuicKeys palette appears when you click outside the
QuicKeys Editor.

CUSTOMIZING QUICKEYS
There are several different ways to customize QuicKeys. You
can make changes in the Configure QuicKeys dialog, set
QuickReference Card preferences, disable/enable QuicKeys
plug-ins, install third-party plug-ins, and sort your Shortcut
list.

SETTING QUICKEYS OPTIONS
You can customize what you see when you run QuicKeys by
selecting or clearing options in the Configure QuicKeys
dialog.

••••
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QuicKeys Menu

Make Icon Options

Use the QuicKeys menu options to select where to display the
QuicKeys menu. You can choose to display the QuicKeys
menu in the Apple Menu, in the menu bar at the top of your
screen, or you can choose to hide the QuicKeys menu. The
Menu Bar option places the QuicKeys icon on the right side of
the Macintosh menu bar. When you change the location of the
QuicKeys menu, you must restart for the change to take effect.

Use the Make Icon options to adjust the appearance of
QKIcons. Select Bullets in Name to add bullets to the QKIcon
filename. Select Use Custom Icons to display an icon that
represents the type of Shortcut selected, rather than a generic
QuicKeys icon. See page 40 for instructions on using the Make
Icon option.

Sequence/Recording Options
Choose whether you want the Record and Playback palettes
to display when you are recording or playing back a
Sequence.

Figure 65: The recording and playback
palettes.
Select Use Sequence Log to provide a log of the last Sequence you
triggered. This feature is useful when you are troubleshooting
a Sequence or when you need to create a building block for a
QuicKeys script. The log file is stored in the System
Folder:Preferences:QuicKeys: folder.

❖
Figure 64: The Configure QuicKeys dialog.

The QuicKeys Backgrounder must be running for
the Use Sequence Log feature to function.

Keyset Management
QuicKeys Popup Menu
Use the QuicKeys Menu options to select which key(s), in
combination with a mouse click, display(s) the QuicKeys
pop-up menu. For example, if you select the Shift check box,
the QuicKeys menu appears whenever you press the Shift key
and your mouse key simultaneously. By default, you can only
open the QuicKeys pop-up menu by clicking the QuicKeys
icon in the menu bar.

Use these options to set compression and memory allocation
preferences. Select Compress files automatically on startup to remove
unused Sequence and Real Time data from their respective
folders when your computer is restarted. To keep things
running smoothly, CE Software recommends leaving this
option selected.

••••

Select Confirm file Shortcuts when compressing files to clean up
QuicKeys at the system level. This option links unattached
File Launch Shortcuts and cleans up empty space that is
fragmented as a result of editing Shortcuts or Sequences.
Specify how much memory you want to reserve for new
Shortcuts. By default, 32K is allocated for new QuicKeys
Shortcuts. Shortcuts vary in size depending on their
complexity, so you need to rely primarily on the QuicKeys
Memory Usage window or persistent buffer alerts to determine
how much of a memory buffer should be set in QuicKeys.
When you are setting your QuicKeys buffer size, keep in mind
that every time you open an application, you open its
associated QuicKeys Shortcut Set, increasing the amount of
memory QuicKeys requires.

Hide QuicKeys Backgrounder
By default, the Hide QuicKeys Backgrounder check box is checked in
the Options dialog. When this option remains checked, the
QuicKeys Backgrounder application is invisible to you when
it is running. If you uncheck this option, the QuicKeys
Backgrounder appears in your application menu. See page 32
for more information on the QuicKeys Backgrounder.
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settings, the alert shown in Figure 66 appears. If you select Yes
in this alert window, the Hide QuicKeys Backgrounder option is
automatically unchecked in the Options dialog so you are able
to see all your toolbars.

Figure 66: This alert window appears if you uncheck the Always On Top
option for a QuicKeys toolbar.

International Launching
Use this dialog to specify the equivalent of various menu
items in a non-English System.

Whether or not the QuicKeys Backgrounder is visible is
largely a personal preference, but this option does affect some
QuicKeys toolbars. If you have a toolbar that does not use the
Always On Top option and you keep the default QuicKeys Editor

Figure 67: The International Launching window.

••••
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Speed Settings
Use the Speed Settings dialog to fine-tune the dragging,
clicking, or recording speeds in QuicKeys. This feature is
useful for applications that are particularly slow or for
creating Real Time Shortcuts for tasks that require slower
movements. The best way to determine which speeds work
best for your environment is to experiment with the different
options.

SETTING QUICKREFERENCE CARD PREFERENCES
Customize the appearance of the QuickReference Card by
making changes in the QuickReference Card Options window.

Figure 69: The QuickReference Card Options window.
Sort by
Sorts Shortcuts in the QuickReference Card window by
Shortcut type, Shortcut name, or keystroke.
Figure 68: The Speed Settings window.

Display these Shortcuts
Choose which plug-ins are displayed in the QuickReference
card by clicking an icon in the QuickReference Card Options
window. A black square highlights each plug-in chosen to
display in the QuickReference Card. By default, all icons are
highlighted.
List
Choose which types of Shortcuts display in the
QuickReference Card from the List options. You can choose to
display Application-specific Shortcuts, Universal Shortcuts, or
both types of Shortcuts.
Expand to fill screen
Expands the QuickReference Card window so it covers your
desktop.

••••

DISABLING/ENABLING PLUG-INS
If you find that you do not have a need for some of the
plug-ins installed with QuicKeys, you can turn those plug-ins
off so they no longer display in the QuicKeys Editor. For
example, if you don’t use your CD-ROM drive for music CDs,
you can disable the CD player plug-in.

51

Get Info
Displays a brief description of the selected extension.

SORTING INFORMATION
Specify how Shortcuts are sorted in the Keysets tab of the
QuicKeys Editor. Just click the category by which you want
your Shortcuts sorted.

To disable/enable QuicKeys plug-ins:

IMPORTING SHORTCUTS
1. Click the Plug-in Manager button
Editor.

in the QuicKeys

2. In the Plug-in Manager window, select the Shortcuts you
want to disable or enable and click the Turn off/Turn on button.
3. Click Done when you are finished.
4. Restart your computer to make your changes take effect.

Import QuicKeys Shortcuts when you receive them from
other QuicKeys users. When you import Shortcuts, you
import all the attributes originally assigned to the particular
Shortcuts.
To import Shortcuts:
1. Open the QuicKeys Editor.
2. Open the Set into which you want to import Shortcuts.
3. Select Import Shortcuts from the File menu. A standard Open
dialog appears.

Figure 70: The Plug-in Manager.
Figure 71: This dialog appears when you import
Shortcuts.
Turn off
Select extensions you don’t use very often and click the Turn off
button to save memory and make your machine run faster.
Restart your computer to make these changes effective.

4. Navigate to the folder where the Shortcuts are stored.

••••
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5. Click the Import without Keystrokes option if you want to assign
your own keystroke to the Shortcut.
6. Click Open. The Shortcuts are imported into the QuicKeys
Set you selected.

EXPORTING SHORTCUTS
Export Shortcuts when you want to share them with other
QuicKeys users.
To export individual Shortcuts and Sets:
1. Open the QuicKeys Editor.
2. Select the Set that contains the Shortcuts you want to
export.
1. Select Export Shortcuts in the File menu.
2. Navigate to the drive where you want to store your
selected Shortcut(s).

EXPORT OPTIONS
Save Selected Shortcuts
Exports only the Shortcuts you select.
Save Entire Set
Exports all the Shortcuts in the selected Set.

LOCKING THE EDITOR
Use the Lock Editor option to secure your Shortcuts or to
standardize Shortcuts across a group of users. If you use
Shortcuts that log into password-protected network volumes,
you may want to restrict people from seeing the specific steps
that comprise the Shortcut. Likewise, if you are a systems
administrator and you don’t want users editing a
standardized set of Shortcuts, you can lock the QuicKeys
Editor on each of the machines on your network.
To lock the QuicKeys Editor:
1. Open the QuicKeys Editor.
2. Select Lock Editor from the Options menu.
3. Type your password in the Enter Password box.

Figure 72: This dialog appears when you choose to export one or
more Shortcuts.
3. Choose Save Selected Shortcuts to export only the Shortcuts
selected in the QuicKeys Editor or choose Save Entire Set to
save all the Shortcuts in the selected Set.
4. Click Open. The Shortcuts are immediately exported to the
location you specified.

Figure 73: The QuicKeys Editor Password dialog.
4. Re-type your password in the Re-enter Password box to verify
the spelling.
5. Click OK when you are finished.

••••

Once you have locked the QuicKeys Editor, you cannot access
the QuicKeys Editor again without entering the password you
selected. After you unlock QuicKeys, the Editor remains
unlocked until you again specify a password in the QuicKeys
Editor Password dialog.

CHECKING MEMORY USAGE
Select Memory Usage from the Options menu to see how QuicKeys
is using memory. If the Buffer Size and the Used categories are
close in number of bytes, you should increase the buffer size.
See the section on keyset management on page 48 for
information on changing the buffer size setting.
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COMPRESSING SETS
QuicKeys Sets are stored in the Keysets folder as individual
files. When you add or delete a Shortcut, QuicKeys adds it to
or deletes it from the appropriate Set.
In contrast, QuicKeys stores Sequences in both the Keysets
folder and the Sequences folder, while Real Time Shortcuts are
stored in both the Keysets folder and in the Macros folder.
When you delete a Sequence or Real Time Shortcut, the file
stored in the Keysets folder is deleted, but the file stored in the
Sequences or Macros folders are not deleted.
The Compress Sets command removes those Sequences and Real
Time recordings if their corresponding Shortcut files have
been deleted. Selecting this option is a good way to streamline
the disk space QuicKeys uses.

❖

Figure 74: The Memory Usage window.
You can get a general idea of whether or not QuicKeys needs
more memory by looking at the Buffer status bar area in the
Info pop-up window in the Quickeys Editor. See Figure 75.

Figure 75: Track the memory buffer size in the Buffer status bar.

By default, Sets are compressed at startup.

